question on Ev2 MK4

Discussion in 'General Airgun Chat' started by waynegal, Oct 10, 2010.

  1. waynegal

    waynegal New Member

    Joined:
    Sep 17, 2009
    Messages:
    42
    Location:
    birmingham & malta
    Hello Friends,I have a MK4 ev and till last weekend it was shooting very consistent 70 shots 775-780 fps and was one of my best rifles to shoot.Today I went to the range and started practising again with the difference of nearly not dropping 6 out of 10 targets .I when`t to check it on chrono and found the rifle shoothing at 657 ftps and reached a maximum of 756 ft/ps after 25 shots .sometimes I had a 20ft/ps shift between shots .It was filled at 180bar as usual using JSB 4.52 8.4 grain .I am from Malta and I am considering send it back to uk for service or selling it coz its a rifle that I can`t work so mhuc on it myself and If I where in uk not mhuc postage to AA and paperwork involved ,I am shooting my 5 th tin of pellets and im really unhappy today .CAn sombody pinpoint a similar problem what can be.
    Any help appreciated,
    Wayne
     
    Last edited: Oct 11, 2010
  2. NJR 100

    NJR 100 Because I`m AWESIME !!

    Joined:
    Aug 10, 2009
    Messages:
    5,577
    Location:
    Skewen
    Club:
    Avon Hawks, Tondu, Oaktree
    Your initial figures of 757 - 780 are not very good for an Ev2 from what i have seen. Most I would say might expect aroud 10-15 at most variation.

    Do the 10 minute test.

    fire a shot over the chrono, or several, note the readings. If they are fairy consistant all well and good.

    Ten leave the gun 10+ minutes and check the 1st shot again. If its dropped 30+ fps, its the not uncommon Ev2 Reg problem and needs a service.

    Have you tried other pellets to see what variation in fps is?

    Have to say it sounds like the Reg needs servicing though?
     
  3. waynegal

    waynegal New Member

    Joined:
    Sep 17, 2009
    Messages:
    42
    Location:
    birmingham & malta
    ev2 problems

    sorry I correct myself ,I edited my post .Its was shooting 775-780 minimum and as you said sometimes going to 15 ft/ps variation,Yes If I leave it in the case to go and have achat with friends for 15 min usually I find it well below 700.You are right about that.
    Wayne
     
  4. WHIZZER

    WHIZZER Member

    Joined:
    Jan 19, 2009
    Messages:
    165
    Location:
    Bowers Gifford, Essex
    leak on the low pressure side of the regulator i believe;)
     
  5. villiers

    villiers Self appointed antipimp

    Joined:
    Nov 25, 2008
    Messages:
    789
    Location:
    Uxbridge UB8
    Club:
    Bisley
    Sadly your reg has failed, the rig pressure is going high in the firing chamber and this results in the low power of the first shot. Very commom fault with EV2s in the UK there are a number of people who repair these regs. Sorry not much help for you were you are.:(
     
  6. luger

    luger Malta's GOS!!!

    Joined:
    Nov 10, 2009
    Messages:
    223
    Location:
    Malta
    Club:
    Malta Allied Airgunners Club
    Hey Wayne, your EV already giving you problems?

    This is your second EV thats messed up and still under guarantee! Take it back, have the reg fixed and hope to God it does not fail again. I knew the EV's were a problematic gun...............:rolleyes:
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice