1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

protarget problems

Discussion in 'Air Arms' started by chrispro97, Jun 20, 2009.

  1. chrispro97

    chrispro97 New Member

    Jun 10, 2009
    purley chase ftc
    last couple of months ive been shooting in rain,wind and red hot sun shine!and loan be hold my gun starts playing up,power going 775fps down to 750fps every 5 shots,i check everything and even changed hammer spring which air arms sent me free of charge,and bugger me it woz still doing it!the dreaded fort of (o no not the reg)but then i notice a build up of crap around the breach seal were you load pellet in,so i poped the seal out cleaned the surface with a cotton bud and check o ring,then placed back in,then i shot it over the chrono 40 shots and loan be hold it only varied 6fps,so the moral of the story make sure this is clean on your protarget dont go what i went through!!!!!!!!!!!!!!!!!!!!!!!!!!
  2. mintyrn10

    mintyrn10 Roll on the weekend!

    Mar 15, 2009
    East yorkshire
    well bugger me i,ve got on doing the same ,, drops 5 fts per shot when i gave it some more on the hammer spring it still did it , bearing in mined that it had a new cylinder and mk3 reg fitted less than a year ago AIR ARMS tell me it probley is the valve with a seating issue as the reg aint venting etc , thats funny that as i did the anglo and it got wet through and then realised i shot the comp on 9.99 ftbs = 750 fts with mozys :eek: i'll try that seal hope it cures it :)


Share This Page