LGV not engaging trigger properly?

Discussion in 'General Airgun Chat' started by Pad. E, Mar 4, 2015.

  1. Pad. E

    Pad. E Member

    Joined:
    Mar 1, 2010
    Messages:
    74
    Location:
    Birmingham
    Hi all

    Just put a scope on the LGV and when cocked and ready to fire it wouldn't shoot? I recocked and then it would fire. Done this about six times until it wouldn't fire at all. Last week I used it without scope for just 10 shots and all was fine.

    I took off the scope recocked and then it fired. Then after the second time shooting it started to fail again?

    Quite annoyed as I am hoping to use this at the British Recoiling Championships at the end of the month.

    Will need to have a look and see what's what.

    I heard that this was an early issue problem, so looks like this one is the same


    Regards
    Paddy
     
  2. valboskie

    valboskie Member

    Joined:
    Oct 9, 2012
    Messages:
    146
    Location:
    Greenock Scotland
    Club:
    NASGARC AND SCOTIA FT
    I had a similar problem with my competition ultra
    I would pullnthe trigger and nothing .
    I had to re cock then wiggle the safety till it fired.
    It gradually got worse till it was every shot .
    A guy at our club adjusted the trigger and that cured the problem he said I had it been adjusted wrong.
    Have you adjusted the trigger recently
    Cheers
    David
     
  3. Pad. E

    Pad. E Member

    Joined:
    Mar 1, 2010
    Messages:
    74
    Location:
    Birmingham
    Hi

    No not touched the trigger at all, taking it to my friend and be having a look. It is one our club guns so not sure if it has been adjusted from one of the other guys though.

    Regards
    Paddy
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice